Перейти к содержимому

Hostmemorylow virtualbox как исправить

  • автор:

Hostmemorylow virtualbox как исправить

Сообщения: 4735
Благодарности: 1418

Конфигурация компьютера
Процессор: Intel G840
Материнская плата: GA-H61M-S2P
Память: Kingstone pc1333 2*1024Mb Kit
HDD: WD 500Gb 16M SATA-II
Видеокарта: NVIDIA GeForce 9500 128Mb
Звук: VIA HD Audio
Блок питания: InWin FSP-300BPF
CD/DVD: Multi-DVD Samsung SH-S223F
Монитор: 20 Samsung 2033N
ОС: Windows XP Professional SP3

Автор: IgNat
Дата: 21-02-2012
Описание: Новая версия программы.

innotek VirtualBox — бесплатная альтернатива VMWare и прочим продуктам виртуализации. Платформа представляет собой систему виртуализации для host-систем Windows, Linux и Mac OS и обеспечивает взаимодействие с гостевыми операционными системами Windows (2000/XP/2003/Vista/Seven/8), Linux (Ubuntu/Debian/ OpenSUSE/ Mandriva и пр.), OpenBSD, FreeBSD, OS/2 Warp. Так же поддерживается работа серверных версий ОС Windows 2k/2k3/2k8. В данной теме обсуждается работа на Windows-host.

Версия — 4.1.8 (released 2011-12-19)

Читать о VirtualBox на OsZone: Oracle VirtualBox

F: как на виртуальной машине подключить папку с реального компа для пользования?? »
Q: Читаем этот пост

F: Брандмауэр блокирует доступ к сети интернет, как настроить?
Q: Читаем этот пост

F: Настройка сетевой папки?
Q: Читаем этот пост

F: Как пробросить порт с гостевой машины?
Q: Читаем краткое пояснение на opennet.

F: У меня проблемы с запуском/импортом/экспортом конфигурации машины?
Q: Основная проблема в данном случае — Вами указан путь к ресурсу содержащий кирилицу и пробелы — это недопустимо.

Благодарности за поддержку ветки (пока я занят или сплю ): gora, maik5, Petya V4sechkin, Morpheus и другим коллегам по форуму.

Не критическая ошибка в VirtualBox

Установил VirtualBox, создал диск, показал образ, и хотел установить систему WinXP на виртуальный комп, когда уже при форматировании диска, перед копированием файлов для установки, выдаёт не критическую ошибку. Вот скрин.
Прога VirtualBox 3.1.6. Пробовал и на портабельной версии, тоже самое.
Подскажите, что не так, в чём ошибка?

94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
Ответы с готовыми решениями:

Критическая ошибка в Sun VirtualBox 3.1.4
При установке программы Sun VirtualBox 3.1.4 винда (XP pro SP3) ругается что программа не прошла.

Критическая ошибка VBox при загрузке Arch
Доброго времени. Собрал себе свежий дистрибутив ArchLinux 2018.01 x86, однако после загрузке падает.

Ошибка VirtualBox
Почему такая ошибка? Не могу использовать существующую виртуальную машину

Ошибка запуска VirtualBox
Ошибка в VirtalBox’e : Недоступна кнопка "Ускорение". Раньше все было нормально, спокойно.

445 / 285 / 50
Регистрация: 10.09.2009
Сообщений: 963

Говорит, мозгов маловато. Либо вы выделили мало оперативной памяти под нее, либо вы жесткий диск не динамический, а статичный сделали, вот и некуда свап писать.

virtualbox.org

[Solved] «HostmemoryLow» and «Unable to allocate and lock memory».

Discussions related to using VirtualBox on Windows hosts.
7 posts • Page 1 of 1
tremas Posts: 4 Joined: 3. Nov 2019, 23:18

[Solved] «HostmemoryLow» and «Unable to allocate and lock memory».

Post by tremas » 3. Nov 2019, 23:28

hola, estoy intentando hacer funcionar un windows 7 32/64 bit, he probado los 2, solo me funcionan con 1024 MB de RAM, my pc tiene 6 GB de RAM total, me gustaria que en total fueran 2GB de ram para la maquina virtual y 4 GB para el Host, siempre que pongo mas de 1024 MB de ram, me dice «Hostlowmemory» y «Unable to allocate and lock memory. The virtual machine will be paused. Please close applications to free up memory or close the VM»

Attachments VBox.log (73.47 KiB) Downloaded 117 times
Last edited by tremas on 6. Nov 2019, 18:51, edited 2 times in total.
tremas Posts: 4 Joined: 3. Nov 2019, 23:18

Re: «HostmemoryLow» and «Unable to allocate and lock memory».

Post by tremas » 3. Nov 2019, 23:29

¡Ocurrió un error durante la ejecución de la máquina virtual! Los detalles del error se muestran abajo. Puede intentar corregir el error y reanudar la ejecución de la máquina virtual.

Unable to allocate and lock memory. The virtual machine will be paused. Please close applications to free up memory or close the VM.

ID error: HostMemoryLow
Gravedad: Error no fatal

scottgus1 Site Moderator Posts: 20010 Joined: 30. Dec 2009, 20:14 Primary OS: MS Windows 10 VBox Version: PUEL Guest OSses: Windows, Linux

Re: «HostmemoryLow» and «Unable to allocate and lock memory».

Post by scottgus1 » 4. Nov 2019, 00:10

tremas wrote: Hello, I am trying to run a Windows 7 32/64 bit, I have tried the 2, they only work with 1024 MB of RAM, my pc has 6 GB of total RAM, I would like them to be 2GB of ram for the virtual machine and 4 GB for the Host, as long as I put more than 1024 MB of ram,

The log says:

00:00:03.082101 OS Product: Windows 10 . 00:00:03.165910 Host RAM: 5939MB (5.8GB) total, 2811MB (2.7GB) available . 00:00:03.332462 RamSize = 0x000000005eb00000 (1 588 592 640, 1 515 MB) . 00:00:17.092267 Console: VM runtime error: fatal=false, errorID=HostMemoryLow message="Unable to allocate and lock memory. The virtual machine will be paused. Please close applications to free up memory or close the VM" 00:00:26.953436 ERROR [COM]: aRC=VBOX_E_INVALID_VM_STATE

Your PC has enough available memory, but it is apparently not all one big piece of memory. The free memory may be in smaller pieces with used memory between the free pieces. According to this post: viewtopic.php?f=6&t=85816 Virtualbox needs a complete piece of memory that is big enough to meet the requirements of the guest settings.

Reboot your PC, then run the guest before running anything else.

Su PC tiene suficiente memoria disponible, pero aparentemente no es todo un gran pedazo de memoria. La memoria libre puede estar en piezas más pequeñas con memoria usada entre las piezas libres. De acuerdo a esto: viewtopic.php?f=6&t=85816 Virtualbox necesita una memoria completa que sea lo suficientemente grande como para cumplir con los requisitos de la configuración del invitado.

Reinicie su PC, luego ejecute el invitado antes de ejecutar cualquier otra cosa..

HostMemoryLow => Fixed in SVN

Описание (последним изменил Frank Mehnert )

  • WinXPsp3 32-bit with VT (dual quad-core E5345 processors)
  • 4 GB RAM
  • NVIDIA Quadro FX 3500 video card, 256 MB VRAM
  • ACPI, IO APIC, VT-x enabled
  • Solaris 10 u5 x86
  • 32- and 64-bit
  • 1524 MB RAM allocated
  • 128 MB VRAM

When running a process in the Solaris guest that worked under Vbox 2.1.4, the guest pauses with this error:

Error ID: HostMemoryLow
Severity: Non-fatal Error

The guest cannot be resumed, and must be powered off. Log file made after brutal power off is attached.

This error happens if the guest is run as 32- or 64-bit. Allocating several hundred more MB of RAM to the guest did not help.

Вложения (1)

rasta_08-2009-04-08-14-17-41.log​ ( 56.4 KB ) — added by rasta 15 лет ago.

Download all attachments as: .zip

История изменений (41)

by rasta , 15 лет ago

Вложение: rasta_08-2009-04-08-14-17-41.log​ added

следующий: 2 comment:1 by Frank Mehnert , 15 лет ago

Краткое описание: Host Memory Low errors stops Solaris 10 guest : Vbox 2.2 → Host Memory Low
Описание: изменено (отличие)

Try to reduce the amount of memory allocated to that VM. It seems that VBox 2.2 on Windows / x86 has some problems allocating suitable memory pages for the guest.

in reply to: 1 comment:2 by rasta , 15 лет ago

I reduced the guest memory allocation to 1280 MB, and the process ran as before. Thank you VERY MUCH for your suggestion.

By the way, the Solaris guest additions for Vbox 2.2 are FANTASTIC, a real improvement. The shared folders work great! However, the Changelog mentions «OpenGL 3D acceleration for Linux and Solaris guests (see chapter 4.8, Hardware 3D acceleration (OpenGL)» but that chapter mentions only Linux and Windows guests. Does the 3d accel really work with Solaris guests or not?

comment:3 by Frank Mehnert , 15 лет ago

Should work with Solaris as well though support is still experimental. The manual was apparently not properly updated.

comment:4 by Marco , 15 лет ago

Same problem «Host Memory Low» in Windows XP SP3 host and guest.

comment:5 by Marco , 15 лет ago

I reduce the memory of the guess to 300MB, and it seems works well.. But in vmware I can have the same vm, with 1024MB.

I have 2GB in my machine.

It seems that have VirtualBox have problems with reserve memmory.

comment:6 by Frank Mehnert , 15 лет ago

Sure, this is a regression and will be fixed. Thanks for your report.

comment:7 by Mathias Eggers , 15 лет ago

I have the following HOST:

Windows Server 2003 (64bit)
8GB RAM
DualCore CPU

Windows Server 2003 Web-Edition (32bit)
750MB — 1GB RAM

On starting all virtual maschines I get the message ‘Host Memory Low’. This message seems to appear if the required memory of all virtual maschines together are 4GB. But there are nearly 3GB free physical memory. So now I can start only 4 maschines.

comment:8 by Riga , 15 лет ago

The same problem on Windows XP SP3 x86 and Win XP x64(!) SP1 during Debian guest x86 and x64 installation. I did’t try 300 mb to guest yet, but 300 is too small for normal tasks. It remains only to wait for a fix.

comment:9 by Christian d’Heureuse , 15 лет ago

I have the same problem with WinXP SP3 host and guest.

comment:10 by c , 15 лет ago

I have the same problem with WinXP SP2 host, It never happends on 2.1.4

comment:11 by eythort , 15 лет ago

same problem here on a winxp pro sp3 host, kubuntu 8.10 guest (1337 MB allocated memory, 128 MB to video mem). Almost 1 GB of host memory free.

comment:12 by Frank Mehnert , 15 лет ago

Краткое описание: Host Memory Low → HostMemoryLow

comment:13 by Frank Mehnert , 15 лет ago

Guest type: Solaris → other

следующий: 15 comment:14 by mgwolters , 15 лет ago

I have exactly the same problem. Everything worked okay untill the install of VB 2.2.0. There is more then enough physical memory on my machine (4 GB) and I have to reduce the memory allocated to the VM’s (all of them: VISTA, Intrepid, Windows 2007) to 512 MB to stop the annoying freezes and HostMemoryLow error. This must be a bug in the new release! To be clear the VM’s are not running together (i.e. at the same time).

in reply to: 14 comment:15 by James Cary , 15 лет ago

Same problem with a Windows host and CentOS 5 guest. Windows host is 32 bit XP SP 3 with 2gb ram. Guest is CentOS 5. Ran fine under previous versions of VirtualBox with 950 MB ram allocated and 32 mb video ram allocated. Now will not run for more than about 10 minutes running eclipse in the Virtual machine if more than 750 mb of ram are allocated.

следующий: 20 comment:16 by Frank Mehnert , 15 лет ago

Краткое описание: HostMemoryLow → HostMemoryLow => Fixed in SVN

We think we found the problem. The fix will be available with the next maintenance release.

comment:17 by tsing Dong , 15 лет ago

I get the same problem ,Windows host is 32 bit VISTA ,memory allocated for the guest is 384MB,Guest OS is cent OS 5

comment:18 by Christian Hoekstra , 15 лет ago

Just additional information that may help or even confirm the problem.

My configuration is:

  • AMD Phenon II X4 920
  • 8GB DDR2, Four Modules
  • AMD 770 Chipset
  • Windows Vista Enterprise, SP1, x86 64-bit
  • When just started, 6GB memory free
  • Windows 2008 x86 64-bit
  • 4096 Memory allocated
  • sATA disks
  • All the CPU features enabled

Problem: When starting the guest, it will show the initial black windows text start up screen, that the guest is paused and vBox presents the already known error message.

However it seems to work as long I do not configure the guest with more that 2048MB memory. Which is in this case an issue, because Windows 2008 x86 64bit Small Business Server requires 4GB of memory to even run.

comment:19 by jo , 15 лет ago

Same problem here. Configuration:

Intel Core 2 Duo 2 Gigs DDR2

Debian 5.0 (Runs out of memory with every permutation of features) Ubuntu 8.10 (Runs out of memory with every permutation of features) OpenSuse 11.1 (Runs out of memory with every permutation of features)

No matter how much memory I allocate to the Linux guests, I have a paused VM without enough memory. I’ve tried enabling and disable PAE, VX-T, and changing the amount of ram present, but to no avail. These worked fine in VBox 2.14.

in reply to: 16 comment:20 by Rakesh Tripathi , 15 лет ago

We think we found the problem. The fix will be available with the next maintenance release.

Do we know when could we expect the next maintenance release ? Is it possible to degrade the VBox version to 2.1.4 (from 2.2.0) as an interim solution ?

comment:21 by jo , 15 лет ago

I was able to uninstall VirtualBox 2.2.0 and reinstall 2.1.4, then add the virtual disks from my old VMs. You’ll have to reconfigure the machines (and rebuild the guest addons if you installed them), but it should work.

следующий: 23 comment:22 by Marco , 15 лет ago

It’s possible to release the exe/dll for this fix? Or the 2.2.1Beta..

in reply to: 22 comment:23 by Thiago Araujo , 15 лет ago

Hi Frank,

It’s possible to release the exe/dll for this fix? Or the 2.2.1Beta..

Thanks

Hi. I agree with marcomsousa. I use VirtualBox in my laptop for many tests, but due to this error I can’t run more than one virtual machine at a time. This is becoming a very critical issue to me, and to many others, I’m sure.

I know you guys have a schedule, and by all means I don’t intend to tell you what to do, for I am not your boss or anything. I also know that a fix is available through SVN, but that’s not an option for me. I just want to bring some more attention to this matter, as it’s really affecting my tests. Please know that I support vbox, and think it is the best virtualization alternative so far.

comment:24 by jo , 15 лет ago

Thirded. VirtualBox 2.2.0 is no longer usable, even with only one VM running and no other programs running.

comment:25 by Harald , 15 лет ago

BTW: VB 2.2.0 runs perfect (with 4 or 5 guests on host XP-x64, 8GB RAM) _before_ last patchday from Microsoft. Any connection?

comment:26 by titantux , 15 лет ago

Still happen to me with VB 2.2.0 Host Vista 2 GB RAM an guest Ubuntu 8.10. I had using 1 Gb with my virtual machine even when warning me about the memory with VB 2.1.4 I had no problems, now I did a try it with 768 MB in RAM and still happen it. Does exist any fix yet ?

Thanks, great work.

comment:27 by Gábor KOVÁCS , 15 лет ago

I’ve the same problem. I’m using Lenovo T61 notebook with 2GB, XP SP3 Host. Various guests, but I cannot run more than one at the same time.

In 2.1.4 I was suffering of hibernation issue of VTx, and I’ve upgraded as soon as 2.2.0 was released.

Have read al the comments under this topic I found that it is some memory allocation error and started to experiment with memory sizes. I did not spent more than 15 minutes.

I found that I could rune two XP guests, with 512MB and 256MB allocated memory.

The original values were 512MB and 384MB, but using those figures I could run only one VM. Whichever I started as the second one, it was paused due to HostMemoryLow and had to be «switched off». Alternatively I was able to save state of the one, then resume the other.

In another experiment with XP/512MB and Vista/512MB guests starting the Vista as the second one caused a more serious problem, because BOTH got paused, and without switching one off, I could not resume either of them.

Guys, I really am an enthusiast of VirtualBox, but such anoying problems making me frustrated. Appart from the repetitive trouble of network adapters upgrading is a smooth thing. You should provide a similar way of downgrading at least to the last previous release. Or provide a simple way of full backup/restore, so that all virtual disks and machine configurations could be backed up to an external harddrive and restored with a rollback to the previous release.

Today, doing so requires so much of efforts, that I try to avoid it, despite VDI backups are taken prior to every single upgrade.

Thanks in advance for considering.

следующий: 29 comment:28 by Chris , 15 лет ago

I have low memory with 3 512MB windows server 2008’s. Title says fixed in SVN, where do I get it?

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *