Тест утечки DNS
Владельцы DNS-серверов, могут отслеживать каждый посещаемый вами веб-сайт и многое другое.
Что означает утечка DNS?
Если установлена утечка DNS, это означает, что ваши запросы к DNS (системе доменных имен) отправляются вне зашифрованного VPN-тоннеля. Ваше устройство продолжает использовать DNS-сервер вашего интернет-провайдера. Посещаемые вами интернет-ресурсы и ваше географическое положение могут быть отслежены третьими лицами.
- Данные интернет-трафика доступны для сбора и перепродажи
- Запросы к сайтам могут быть отслежены
- Возможен перехват DNS-запросов и подмена ответа сайта злоумышленниками
Чтобы узнать больше о том, что такое DNS, прочтите нашу статью по ссылке
Чем грозит утечка DNS
При обращении к системе доменных имен трафик не шифруется, а значит при утечке DNS можно определить откуда именно и к какому сайту пользователь сделал запрос. Утечка DNS раскрывает ваше реальное географическое положение, лишая вас анонимности.
Третьи лица (ваш провайдер, ваш работодатель) могут получить доступ к посещенным вами ресурсам. Злоумышленники могут использовать эти сведения для организации фишинговых атак или внедрения вредоносного кода.
Почему мой DNS виден, если я использую VPN?
Часто, даже при подключении VPN-сервиса вы можете столкнуться с утечкой DNS. Есть несколько основных причин отображения реального DNS-сервера при смене IP с помощью впн-программ.
Ваш VPN-сервис настроен некорректно
Ваше устройство подверглось хакерской атаке
Ручная настройка DNS
Как Whoer VPN защищает от DNS утечки
Whoer VPN предоставляет своим пользователям надежную защиту от DNS-утечек. При подключении впн-клиента Whoer, запросы на DNS вашего провайдера прерываются и перенаправляются на собственные быстрые DNS-серверы Whoer VPN, таким образом, что ваш DNS соответствует IP-серверу подключения. Сервис не сохраняет логи и любые данные об активности пользователей, а ваш интернет-трафик остается анонимным и конфиденциальным.
Собственные быстрые DNS-серверы Whoer VPN гарантируют безопасность и надежность соединения и отсутствие ограничений доступа на основе географического положения.
Whoer VPN не ведет логи и не отслеживает действия пользователей, ни в платном, ни в бесплатном тарифе.
Используя Whoer VPN интернет-трафик между вашими устройствами и DNS-серверами защищены AES-256 шифрованием.
Как это работает?
- Чтобы перейти на нужный вам сайт, вы вводите в строке браузера его имя, либо переходите по ссылке.
- Whoer VPN клиент преобразует имя сайта в зашифрованный код и по защищенному каналу отправляет на собственный DNS-сервер.
- DNS-сервер Whoer VPN моментально получает IP-адрес запрашиваемого сайта и в зашифрованном виде передает его обратно пользователю.
- Вы получаете доступ к сайту, при этом все данные запроса и ваше реальное местоположение скрыты от вашего провайдера и третьих лиц.
Команда Whoer.net — признанные эксперты в сфере интернет-безопасности. Мы знакомы с каждым аспектом анонимности и конфиденциальности в Сети. Мы защищаем данные наших пользователей, полностью отказавшись от записи логов, чтобы никто не мог получить доступ к ним.
Как начать пользоваться Whoer VPN
Регистрация
Выберите план подписки Whoer VPN без рисков. Гарантия возврата денег 30 дней. Отсутствие скрытых автоплатежей.
Скачайте
Скачайте и установите приложение Whoer VPN. Подробная инструкция по ссылке
Подключитесь
Откройте VPN-клиент, введите полученный после регистрации код и подключайтесь к одной из локаций серверов.
Предотвратите утечки DNS
Утечки DNS представляют собой серьезную угрозу для вашей конфиденциальности в Интернете. Используя зашифрованный туннель VPN от Proton VPN, вы сможете всегда сохранять конфиденциальность, безопасность и защищенность ваших данных и действий в Интернете. Наши функции также включают:

Что такое утечки DNS и как их предотвратить?
Когда вы посещаете сайт, ваш браузер посылает запросы в систему доменных имен (DNS), чтобы найти нужную вам веб-страницу. DNS переводит используемые нами доменные имена (например, protonvpn.com) в IP-адреса, которые используют компьютеры. Если эти запросы DNS не зашифрованы, ваш поставщик услуг может следить за вашими действиями, как и кто-либо другой. Proton VPN предпринимает несколько шагов, чтобы гарантировать, что ваши запросы DNS никогда не будут раскрыты.
Ваши запросы DNS зашифрованы
Наши приложения VPN автоматически шифруют ваши запросы DNS и включают их в туннель VPN, это означает, что они не могут быть перехвачены или прочитаны при передаче третьими лицами.
Мы используем собственные серверы DNS
Сервер Proton VPN имеет сервер DNS, который будет обрабатывать ваши запросы DNS. Ни одна третья сторона никогда не имеет к ним доступа в незашифрованном виде, включая вашего интернет-провайдера и провайдера DNS.
Проверка утечки DNS
Вы можете проверить защищенность вашего подключения к VPN, подключившись к серверу, перейдя на сайт проверки утечки DNS (new window) и выполнив стандартную или расширенную проверку. Если результаты показывают серверы DNS, которые не принадлежат вашему действительному провайдеру, ваше подключение к VPN защищено.
Больше протоколов для шифрования DNS-запросов

Дискуссия вокруг DNS-over-HTTPS и DNS-over-TLS не утихает до сих пор. Регуляторы, телекомы и интернет-регистраторы спорят о преимуществах и недостатках протоколов. На фоне этого в борьбу вступают альтернативные решения. Они пока не получили обширной поддержки, но все еще может измениться. Сегодня обсудим DNS-over-QUIC и DNS-over-CoAP.
Быстрая альтернатива
QUIC — это транспортный протокол на базе UDP, который представили инженеры из IETF и Google. Он вполне соответствует своему названию и обладает большей производительностью по сравнению с аналогами. Например, позволяет установить соединение со знакомым сервером в одно рукопожатие. В то же время протокол предлагает дополнительные защитные механизмы — шифрует данные и требует аутентификации получателя пакетов.
Эти особенности полезны при работе с DNS, поэтому в прошлом году IETF одобрили стандарт DNS-over-QUIC (DoQ). Его даже оформили в формате RFC 9250, хотя это событие прошло без ярких заголовков.
Протокол решает проблему head-of-line-blocking и заточен под нестабильные сети с потерями пакетов. При этом он подходит для работы как с рекурсивными, так и авторитативными DNS-серверами. Так, по сравнению с классическим DNS-over-HTTPS, DoQ применим на большем спектре задач.
Разумеется, не стоит ждать, что новый протокол получит широкое распространение в ближайший месяц. Но спецификация находилась в разработке пять лет, поэтому некоторые реализации уже существуют. Есть больше тысячи резолверов с поддержкой DoQ. Среди них 45% работает в Азии, 32% в Европе и 18% в Северной Америке.
Существует и несколько реализаций DoQ. Quicdoc, основанный на Picoquic и написанный на C, библиотека aioquic на Python и DNS-инструмент для функционального тестирования Flamethrower. Со временем число таких решений продолжит расти. Как минимум потому, что с приходом HTTP/3 классический DoH будет поддерживать работу с QUIC.
Специально для интернета вещей
DNS-over-QUIC не единственный протокол, который приходит на арену шифрования DNS-запросов. На прошлой неделе международная группа инженеров предложила стандарт DNS-over-CoAP (DoC), ориентированный на развертку в сетях IoT.

Он подразумевает передачу DNS-сообщений по Constrained Application Protocol (CoAP) с протоколом безопасности Object Security for Constrained RESTful Environments (OSCORE). Он основан на объектах данных и позволяет обмениваться сообщениями CoAP через промежуточные узлы со сквозной защитой.
DoC-клиент шифрует DNS-запрос в одном или нескольких CoAP-сообщениях (RFC8132). Запрос поступает DoC-серверу, который его обрабатывает. Он может работать как stub-резолвер (RFC8499) или рекурсивный резолвер (RFC8499). В целом процесс работы с DNS-сообщениями может выглядеть следующим образом:
FETCH coaps://[2001:db8::1]/ Content-Format: application/dns-message Accept: application/dns-message Payload: 00 00 01 20 00 02 00 00 00 00 00 00 07 65 78 61 [binary] 6d 70 6c 65 03 6f 72 67 00 00 1c 00 01 c0 0c 00 [binary] 01 00 01 [binary]
Протокол находится на ранних этапах обсуждения, поэтому авторам предстоит проделать еще много работы — в частности, дополнить механизмы безопасности, чтобы противостоять более широкому набору кибератак. Внести предложения до 13 сентября 2023 года могут все желающие — для этих целей драфт документа разместили в репозитории на GitHub.
Функция шифрования DNS: дополнительный уровень защиты или очередная проблема
Несомненно, информация — один из самых ценных ресурсов в мире. Поскольку сегодня почти все сферы жизни связаны с Интернет-сетью, обеспечение защиты личных данных онлайн и их безопасное использование стало одной из самых актуальных тем современности.
В частности, самыми обсуждаемыми вопросами являются шифрование DNS и последствия его использования для пользователей. Локальный DNS действует как адресная книга в Интернете и обеспечивает направление на нужную страницу при отправке или получении данных с сервера (например, при введении адреса сайта в строку URL-адресов).

Поскольку сегодня много персональной информации распространяется Интернет-сетью, шифрование стало традиционным способом обеспечения конфиденциальности, например, шифрование текстовых сообщений или использования VPN во время работы в Интернете. Как и многие протоколы Интернета, DNS остается до сих пор открытым и общедоступным для всех.
В начале этого года Google и Mozilla опубликовали информацию о переходе к шифрованию DNS с помощью DNS-over-HTTPS (DoH). Обычно, информация о DNS-запросах незашифрованная, это означает что ваш Интернет-провайдер, другие серверы и пользователи вашей сети Wi-Fi могут видеть сайты, которые вы посещаете.
Такую возможность часто используют киберпреступники для распространения различных угроз, которые могут влиять на систему доменных имен жертвы. В частности, злоумышленники направляют пользователей на поддельный веб-сайт для загрузки вредоносного кода и заражения устройства. Для этого киберпреступники обычно используют фишинговые ссылки, эксплойты и ботнеты.
Тогда как шифрование DNS предотвращает кражи данных и уменьшает риски атак киберпреступников. «Одной из причин большого количества киберпреступлений и мошеннических операций в Интернет-сети является отсутствие соблюдения основных правил безопасности при работе со старыми Интернет-протоколами и сервисами», — отмечает доктор Пол Викс, который исследовал DNS. Однако это не означает, что полное шифрование — единственный способ защиты от угроз, которые используют устаревшие протоколы.
В чем опасность шифрования DNS?
Существует мнение, что шифрование DNS может вызвать ряд определенных проблем. В частности, некоторые специалисты по кибербезопасности утверждают, что шифрование DNS может затруднить обнаружение вредоносных программ в Интернет-сети. Это особенно актуально для предприятий, где прозрачность DNS имеет решающее значение для обеспечения защиты сети.
Самое главное, что шифрование DNS не позволяет пользователям одной сети видеть запросы других. Сейчас Интернет-провайдеры могут использовать информацию DNS-запросов для отправки конкретных рекламных объявлений или с целью контроля сетей в случае нарушения авторских прав. Таким образом, шифрование DNS обеспечивает конфиденциальность и безопасное управление данными, однако это не позволяет пользователям полностью контролировать доступ к личным данным.
В любом случае выбор о переходе к шифрованию DNS не зависит от пользователей, а остается за основными технологическими компаниями. И хотя шифрования DNS может препятствовать доступу провайдерам к данным пользователей, технологические корпорации могут использовать такую возможность в своих целях.
- Предыдущая новость Основные правила защиты данных — кибергигиена для активного Интернет-пользователя
- Следующая новость Как полностью удалить данные с устройства перед продажей — основные рекомендации