Перейти к содержимому

Как открыть 25 порт

  • автор:

Как проверить 25 порт

Для того, чтобы проверить email адреса, программе ePochta Verifier нужен интернет и симуляция отправки письма на адрес. Это происходит через порт 25, который требуется для работы SMTP-протокола и иногда закрывается интернет-провайдерами.

ePochta Verifier имеет в своем арсенале 3 режима проверки:

  • через прямое подключение
  • через скрипты
  • через прокси-сервера

Каждый режим имеет свои особенности и назначение. Если 25 порт закрыт интернет-провайдером и проверка через прямое подключение невозможна, рекомендуется использовать проверку email адресов с использованием скриптов на веб-сайтах. На нашем сайте представлена детальная инструкция по работе со скриптами и активации этого режима проверки.

Как проверить открыт ли 25й порт или нет?

Нажмите «Пуск» — «Выполнить». В появившимся окне пропишите «cmd» и нажмите «ок».

В окне командной строки пропишите «telnet адрес_smtp_сервера 25».

Нажмите «Enter». В Windows 7,8,10 утилита telnet может быть отключена, в таком случае следует ее включить: «Пуск» — «Панель управления» — «Программы» — «Программы и компоненты» — «Включение или отключение компонентов Windows». Далее нужно поставить галочку возле пункта «Клиент Telnet».

Если у вас появилось приглашение от сервера, значит порт открыт.

Если у вас появилось приглашение от сервера, значит порт открыт.

Что же делать если 25й порт закрыт?

  1. Если ISP не блокирует порт 25, а ePochta Verifier пишет, что он закрыт, вероятней всего ваш антивирус заблокировал программу. Выключите его на некоторое время и повторите процедуру заново. Также можно добавить программу ePochta Verifier в исключения антивируса. Как это сделать вы узнаете ниже:
    Avast: http://www.getavast.net/support/managing-exceptions
    Eset NOD32 Smart Security: http://support.eset.com/kb2769/?locale=en_US
    Kaspersky Internet Security: http://support.kaspersky.com/11146#block2
    AVG: https://support.avg.com/SupportArticleView?l=en_US&urlName=How-to-exclude-file-folder-or-website-from-AVG-scanning
  2. Обратитесь к своему провайдеру с просьбой открыть порт 25. Если ваша просьба будет отклонена, ищите другого интернет провайдера.
  3. Ищите Wi-fi с открытым 25м портом. Wi-fi будет предоставляться другим провайдером и есть вероятность, что порт 25 будет открыт.

Задайте вопрос специалисту технической поддержки

Ошибка, порт 25 не доступен. SMTP, проверка с помощью telnet

Отправка почтовых сообщения из клиента происходит через установку соединения с удаленным почтовым сервером, который у вас указан в настройках на порт 25 почтового сервера, но так бывает что провайдер блокирует данный порт с целью предотвращения спам рассылок из своей сети. Мы предлагаем сделать проверку блокируется ли порт 25 вашим провайдером.
В качестве адреса почтовго сервера здесь приводится сервер mail5.freehost.com.ua, вместо него вы можете подставить свой почтовый сервер с которым у вас возникли проблемы.

Начинаем с того что заходим в меню Пуск, для Windows, вводим комманду cmd, тут же OC Windows подсветит нам приложение.

Перед нами откроется окно коммандной строки, вводим комманду telnet и жмем ENTER. В случае если выдаст ошибку что комманда не найдена, возможно у вас в системе не установлен компонент «клиент telnet», как его установить дальше.

1. Установка telnet клиента (актуально для новый версий ОС Windows)

2. Выбиваем меню «Программы», «Включение и отключение компонентов Windows».

3. Появляется окно компонентов (тут идет задержка, так как системе требуется время чтобы составить перечень компонентов установленных в ОС)

4. Отмечаем установку компонента «Клиент Telnet» и жмем OK

5. Ожидаем пока компонент добавится.

6. После установки компонента Telnet, переходим снова к окну коммандной строки и вводим комманду telnet

7. Вводим комманду для установки соединения с нашим сервером «open mail5.freehost.com.ua 25» (напоминаем, в качестве сервера мы используем наш адресс mail5.freehost.com.ua, вам же надо вводить свой с которым у вас возникают проблемы). В комманде мы говорим, open — открыть соединение, mai5.freehost.com.ua — адресс нашего сервера, 25 — это порт на который производится установка соединения (используется по умолчанию для почтовых серверов).

8. Если все нормально, мы увидим превественное сообщение нашего почтового сервера. (Тут приветственные сообщения могут отличатся при ипользовании разных серверов, но основное отличие, что когда вы выдите эту строку это уже хорошо.)

9. Введем комманду HELP чтобы узнать какие комманды поддерживает наш сервер, после чего разорвем установленное соединение коммандой quit

10. После разрвы соединения увидим примерно такое:

11. Пока все идет хорошо, но порт 25 это порт для приема сообщения почтовым севером, со стороны клиента это звучит как отправка почтового сообщения, но мы теперь проверим возможность приема почтового сообщения, вводим комманду «open нашсервер 110»

12. Результатом выполнения комманды будет установка соединения и вывод приветственного сообщения нашим сервером

13. Как видим все хорошо, закрываем соединение вводом комманды quit

Как видим, все наши проверки закончились с успехом, а теперь покажем что бывает когда возникают проблемы:

14. Открываем соединение с сервером где провайдер производит блокировку порта 25

15. Долго висит надпись: Подключение к нашему серверу, после чего появляется ошибка что соединение не удалось установить

16. Попробуем установить соединение с другими открытыми SMTP серверами других провайдеров, чтобы окончательно убедится что блокировка происходит именно у нашего провайдера или нашей сети:

17. Везде одна и таже ситуация, тут вариант только один, обратится в поддержку нашего провайдера за разьяснениями и возможно попросить их разблокировать порт, так как не всегда ситуация с блокировкой является легальной процедурой. Ну а мы пока попробуем проверить, можно ли использовать альтернативные порты для подключения к почтовым серверам (многие почтовые сервера имею несколько портов для установки соединения, как раз связано со случаями блокировки SMTP трафика со стороны провайдера или компании).

18. Соединение установилось, пробуем выполнить комманду HELP (это пример и в некотых почтовых серверах по умолчанию отключена), после чего снова с помощью комманды quit закрываем соединение

19. Попробуем альтернативный порт к другим почтовым серверам

20. А вот пример где соединение установилось, но комманда HELP не поддерживается со стороны сервера

На этом краткая инструкция по диагностике завершена, вам требуется указывать адрес своего почтового сервера для проверки достаности его почтового порта из вашей сети.

Как видно ситуации бывают разные, но если ваш сервер и другие сервера не доступны по порту 25 из вашей сети, но спокойно доступены по альтернавтиным портам вам требуется обратится к вашему провайдера (ну или использовать альетрнативные порты которые требуется указать в почтовом клиента в параметрах сервера для отправки почтовых сообщений).

  1. Как изменить ДНС сервера для моего домена?
  2. Реселлерская программа по регистрации доменов для клиентов VPS и физических серверов.
  3. Мой дамп mysql-базы занимает больше, чем разрешено заливать через phpMyAdmin. Что делать?
  4. Мой сайт на VDS выдает ошибку PHP типа «Allowed memory size of X bytes exhausted (tried to allocate Y bytes)»
  5. Сайт выдает ошибку «Call to undefined function. «
  6. Сайт выдает ошибку «Can’t connect to database server» или подобную.
  7. Сайт работает, но очень медленно.
  8. Сервер DNS second.freehsot.com.ua что это и зачем?
  9. Как выполнить перезагрузку физического сервера?
  10. Как заказать дополнительный IP адрес?
  11. Можно ли перейти на более производительный физический сервер без перестановки системы?
  12. Как продлить услугу сервера?
  13. Я забыл свой пароль на FTP от сервера резервных копий. Что делать?
  14. Настройка мониторинга веб сервера apache с помощью модуля mod_status
  15. Сервера с IPMI
  16. Мой провайдер заблокировал 25 порт, не могу подключится к своему серверу.
  17. Подключение по VPN к серверу с IPMI
  18. Ошибка, порт 25 не доступен. SMTP, проверка с помощью telnet
  19. Диагностировка с WinMTR
  20. Логи web-сервера apache
  21. Ошибка недоверенное соединение
  22. Восстановление баз данных MySQL с таблицами myisam и innodb
  23. Установка панели Vesta и размещение сайта на примере wordpress
  24. Настройка кеширования в Worpdress с помощью плагина W3 Total Cache и memcached

База знаний

Стандартный порт, который используется для соединения к протоколу SMTP — порт 25. Одна из наиболее вероятных и часто встречающихся причин ошибки при попытке отправить почту — блокирования 25-го порта со стороны Интернет-провайдера. В данной ситуации есть два варианта. Первый — использовать VPN, второй — использовать альтернативный порт.

Чтобы проверить, заблокирован ли со стороны интернет-провайдера 25-й порт, выполните такую комманду:

Windows

Пуск -> Все программы -> Стандартные -> Выполнить -> cmd -> telnet ваш_сайт.com 25

Start -> All programs -> Basic -> Run -> cmd -> telnet ваш_сайт.com 25

MacOS

Mac HD -> «Applications» directory -> Utilities sub-directory telnet ваш_сайт.com 25

Linux

Откройте терминал и введите команду:

telnet ваш_сайт.com 25

Если 25 порт открыт, вы увидите похожее сообщение с ответом сервера:

220 example.com ESMTP Postfix

Если же такого сообщения не появилось, но Вы увидели сообщение об ошибке соединения — порт заблокирован!

Почему заблокирован 25-й порт? Большинство интернет-провайдеров блокируют 25-й порт, потому как он используется для рассылки спам-сообщений.

  • 2 Пользователи нашли это полезным

Related Articles

Наша компания помогает своим клиентам в переносе сайтов на наши сервера. Для получения этой.

Доступ через почтовый веб-интерфейс Для доступа к почтовому ящику через веб-интерфейс.

Доступ через Microsoft Office Outlook 2010 Чтобы настроить Microsoft Office Outlook 2010.

Файл robots.txt – это текстовый файл, находящийся в корневой директории сайта, в котором.

Код состояния HTTP — это часть строки заголовка, ответа веб сервера на запрос клиента.

Как правильно открыть 25 порт на сервере?

Внезапно перестал работать 25 порт. Раньше было такое, но открыл и все нормально. А сейчас ни в какую.

iptables -I INPUT -i eth0 -p tcp --destination-port 25 -j ACCEPT iptables -I INPUT -i eth0 -p udp --destination-port 25 -j ACCEPT service iptables save service iptables restart
-P INPUT ACCEPT -P FORWARD ACCEPT -P OUTPUT ACCEPT -N fail2ban-SSH -A INPUT -p tcp -m tcp --dport 25 -j ACCEPT -A INPUT -p udp -m udp --dport 25 -j ACCEPT -A INPUT -i eth0 -p udp -m udp --dport 25 -j ACCEPT -A INPUT -i eth0 -p tcp -m tcp --dport 25 -j ACCEPT -A INPUT -p tcp -m tcp --dport 25 -j ACCEPT -A INPUT -i eth0 -p tcp -m tcp --dport 110 -j ACCEPT -A INPUT -i eth0 -p tcp -m tcp --dport 143 -j ACCEPT -A INPUT -i eth0 -p tcp -m tcp --dport 25 -j ACCEPT -A INPUT -i eth0 -p udp -m udp --dport 25 -j ACCEPT -A INPUT -i eth0 -p udp -m udp --dport 143 -j ACCEPT -A INPUT -i eth0 -p udp -m udp --dport 110 -j ACCEPT -A INPUT -i eth0 -p udp -m udp --dport 53 -j ACCEPT -A INPUT -p tcp -m tcp --dport 22 -j fail2ban-SSH -A INPUT -i eth0 -p tcp -m tcp --dport 3306 -j ACCEPT -A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT -A INPUT -p tcp -m tcp --dport 8070 -m comment --comment "Access to manager of pool" -j ACCEPT -A INPUT -p tcp -m state --state NEW -m tcp --dport 22 -j ACCEPT -A INPUT -p tcp -m tcp --dport 80 -j ACCEPT -A INPUT -p tcp -m tcp --dport 443 -j ACCEPT -A INPUT -p tcp -m tcp --dport 8890 -j ACCEPT -A INPUT -p tcp -m tcp --dport 8891 -j ACCEPT -A INPUT -p tcp -m tcp --dport 8893 -j ACCEPT -A INPUT -p tcp -m tcp --dport 8894 -j ACCEPT -A INPUT -p tcp -m tcp --dport 5222 -j ACCEPT -A INPUT -p tcp -m tcp --dport 5223 -j ACCEPT -A INPUT -p icmp -j ACCEPT -A INPUT -i lo -j ACCEPT -A INPUT -j REJECT --reject-with icmp-host-prohibited -A INPUT -i eth0 -p tcp -m tcp --dport 3306 -j ACCEPT -A INPUT -i eth0 -p tcp -m tcp --dport 3306 -j ACCEPT -A INPUT -i lo -p tcp -m tcp --dport 3306 -j ACCEPT -A FORWARD -j REJECT --reject-with icmp-host-prohibited

локально телнет на 25 порт проходит, а удаленно нет.

  • Вопрос задан более трёх лет назад
  • 3867 просмотров

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *